I had a NW6.5 server with fully updated service packs fail on me today.
It runs GWIA and an MTA, as well as a HTTP Proxy through bordermanager,
and surf control for web filtering.

Before it was rebooted, it was reporting no hard drive space (through
bordermanager's http proxy and a check of the sys volume). When I
rebooted I got a number of error messages:

NCPNLM32.NLM (AUTO FAIL)
NETNLM32.NLM (AUTO FAIL)
DSEVENT.NLM (AUTO FAIL)
TIMESYNC.NLM (AUTO FAIL)
CLXNLM32.NLM (AUTO FAIL)

Loader cannot find public symbol NWDSFreeContext for module NLSMETER.NLM
Loader cannot find public symbol NWCALLSInit for module SERVINST.NLM

(plus a few other loader cannot find's)

SPMNWCC.NLM (AUTO FAIL)
NMAS.NLM (AUTO FAIL)

SERVINST.NLM load status unresolved

PKIAPI.NLM (AUTO FAIL)
PKI.NLM (AUTO FAIL)

The last thing it is trying to load is NICISDI.XLM

I also get:

WARNING Server CJ2 experienced a critical error. The offending process
was suspended or recovered.... services hosted may be affected.

It appears to mount the sys volume, as I can get to it from a workstation.
I cannot edit AUTOEXEC.NCF, however, as it is being used.

I freed up some space and did a reboot, to no avail.

There are a bunch of errors in the abend log, but nothing I can get
anything useful out of:

---------------------------------------------

Server CJ2 halted Thursday, June 28, 2007 5:34:26.508 pm
Abend 1 on P00: Server-5.70.05: Page Fault Processor Exception (Error code
00000000)

Registers:
CS = 0008 DS = 0010 ES = 0010 FS = 0010 GS = 0010 SS = 0010
EAX = 0000D36D EBX = 8A30C9EC ECX = FE001F44 EDX = 00000001
ESI = 8A30C7A0 EDI = FE00C000 EBP = 8A30C520 ESP = 8A30C48C
EIP = 002A1E60 FLAGS = 00010292
002A1E60 8B4804 MOV ECX, [EAX+04]=?
EIP in SERVER.NLM at code start +0009CD60h
Access Location: 0x0000D371

The violation occurred while processing the following instruction:
002A1E60 8B4804 MOV ECX, [EAX+04]
002A1E63 8954242C MOV [ESP+2C], EDX
002A1E67 85C9 TEST ECX, ECX
002A1E69 0F846E040000 JZ 002A22DD
002A1E6F 833D70B2420000 CMP [SERVER.NLM|ModuleBeingUnloaded]=00000000,
0000
0000
002A1E76 0F848E040000 JZ 002A230A
002A1E7C 8B3504300600 MOV ESI, [LOADER.NLM|RunningProcess]=8A3060A0
002A1E82 56 PUSH ESI
002A1E83 E84813F8FF CALL SERVER.NLM|TcoGetThreadType
002A1E88 83C404 ADD ESP, 00000004

---------------------------------------

I can't seem to get a clean boot. Anyone have any ideas?