I tried posting this in the novell.support.edirectory.linux forum and
was referred here.

I'm trying to set up LDAP authentication to SLES9 via eDir following the
steps outlined in the "AppNote: Basic Linux/Samba authentication with
eDirector on Novell Linus Small Business Server". The document indicates
that the procedure should work on "any SLES9 base systm". I've tested
this in a lab environment and everything worked fine. I have now tried
to duplicate this is a live environment and I fail on getting the LDAP
authentication to eDirectory. I have the following environment:
SLES9 sp2
As per the document, I also have the prerequisites installed
Edir 873. (the server is installed into an existing tree with 2 Netware
I get as far as step 6 "Test Linux authentication" and get the following
error when I try to assign ownership of the newly created home directory
to the edir user: chown: "dummy.SambaGroup": invalid user

DS trace on the server yield the following error message:
Failed to authenticate local on connection 0x85da8c0, err = failed
authentication (-699)

suspecting a problem with SSL, I altered the configuration to not use
SSL (unchecked the TLS box on the LDAP Group Object, unchecked the TLS
box on the LDAP Client cfg in YAST2). I get the following error message
NDS attribute "staticMember" does not exist, mapping ignored
Failed to authenticate local on connection 0x85da8c0, err = failed
authentication (-699)

Just to make sure that LDAP is functioning with SSL/TSL I was able to
use the ICE tool both in iManager and in ConsoleOne to export data as
well as make the schema changes the the AppNote calls for. I also could
use a LDAP brower on port 636 to browse the tree, both with anonymous
access (I've defined an LDAP proxy user for the LDAP Group Object) and
with the admin user.

DSrepair on all servers yields no errors at all so I must assume that
eDir is correctly installed. the edir installation also gave no errors
on the CA und NMAS parts of the installation. the SAS, and server
certificate objects were created as well. I know on Netware, a
RootCert.der file is created in sys:public. I cannot determine if such
files were created automatically as I do not know where to look. I do
know from the AppNote that there should be a SSCert.der file in
etc/opt/novell This file was not present, but I created it by exporting
the Trusted Root certificate associated to the SLES9 server in the
server container. From my research in the forums I've seen mention of a
SSCert.pem file. I do not believe I have one on the SLES9 server. Do I
need it? How do I generate it? Where must it be placed on the server?

The ultimate goal here is to get samba access to the SLES9 server using
the eDirectory accounts

If anyone has similar experience or perhaps advice how to get Linux
authentication with LDAP/eDir, I would appreciate it.