I don't know if this was created by using "rug" to install updates or not,
but when I go into yast, I am shown a dependency conflict.

Select Kernel

Required by:

adminfs requires kernel=2.6.5-7.244

Conflict Resolution:

Install kernel-bigsmp
Install kernel-debug
Install kernel-default
Install kernel-smp
Ignore conflict and reisk system inconsistencies

Which kernel should I pick? What's the difference between bigsmp and smp?