We have a cluster of 8 Novell OES Linux servers, all SP2 en quite recently
patched (patched most of them yesterday, have still 2 on a patchlevel of
November). We had some troubles with installing due to badly configured
HBA's but after the problemns were resolved all seemed well. We're
planning to put it into production soon (we finally got our badly needed
NSS-patch for Dataprotector) so checked some things on the server. I
discovered that a few of the servers were installed with the wrong account
(which was a temporary admin-account for an external consultant/engineer).
Because this account was disabled some services had troubles logging into
eDir. I tried to solve this by changing the account by which OES logs in
on eDir. One of the thing I had to reconfigure was NSS. On 2 servers it
went without a glitch but the rest fails. Yast/Yast2 hangs and spams its
log (and the terminal window) with this message:

2006-12-20 14:48:46 <3> ALG-CL-08(14604) [bash]
ShellCommand.cc(shellcommand):73 *** glibc detected *** double free or
corruption (out): 0x40295958 **

Even the rolloverlogs are full with it. I've tried looking for any clue on
the Novell-site and on Google but sadly nothing that led me to a solution.

I've changed the LDAP-config, the /etc/nam.conf but I think this has
something more to do with a bug than not being able to logon to eDir/LDAP.

Anyone any clues ??


Marcel Tempelman
Deltion College Zwolle
The Netherlands