I am new to Linux. We are installing our first OES server for a new
project. The first requirements are:

Linux 2.2 Kernel required
I found this with uname -r
OES uses 2.6.5-7-default

Java is required. JDK or JRE 1.3.1
I am using version 1.4.2_03

Glibc version 2.1.3 and version 2.1.92 are support
I need to know how to check my version. I did a google search and some
say to use the ldd --version which gives me the GNU Libc as 2.3.3 but I
don't know if that is the LDD version of GLIBC version. Also some say to
check the file /lib/glibc- but it's not there. Maybe it is not
installed by default.

LIBSTDC++ 2.9.0 is supported
How do I check on this as well.

I am new to Linux and have been reading a lot of books on Linux and OES
but I still have problems remember some syntax and ways to accomplish
some stuff. I would appreciate any help.

Thank You,

John Jakus