I have some trouble installing the Promise Supertrack EX 8350 and contacted
the support att Promise a couple of times. The OES SP2 seems to use the same
kernelversion as SLES SP3. When installing the system with the drivers that
can be downloaded from Promise it all works fine but when rebooting the
system it starts to use the more advanced kernel with smp.

The I reinstalled the system att added kernels for default, smp and big-smp.
With some testing it shows that the driver only works with the default
kernel. When i contacted Promise again the recommended the open source
verion of the driver that also exists on promises site. I added the kernel
source and used the config files from the /boot-directory to i would get the
right configuration. Compiled the driver 3 times with the different
kerneltypes using the instructions from Promise. Replaced the original
drivers from Promise with the ones that i compiled.

When testing the system only the default version works. The very same error
for both the other kernels, the same error as the original Promise driver
had. I contacted them again and all they said was that i should get the
latest patch kernels. I upgraded my system with the latest that could be
downloaded from Novell. I tested the original promise drivers with the
kernel and i also compiled my own. No change.

I asked them if there was any newer drivers and the said that the open
source community was developing their driver. I checked at kernelsource and
found that the driver is now included in the kernelsource. Sorry to say but
that didn't help me at all because then i would have to compile a new kernel
because the source is so different and needs other components that isn't in
the original kernel.

I have noticed that the kernel numbering in the server kernel is a alot
different than the numbering of the desktop kernels. Are there any logic
behind that numbering? Will the OES SP3 kernel have native support for my
card as the latest kernels from the kernelsources have?

Constructive ideas?

The error from the system boot:
Stex: Promise Supertrack Stex: (0000:03:0E.0) lost interrupt after a while:
Device offlined - not ready after error recovery host 0 channel 0 id 0 lun 0

It the repeats for every ID.

Best wishes!