I've got an OES for Linux server on a private network that uses a proxy
to access external sites but should access internal sites directly.

I've therefore configured http_proxy and no_proxy accordingly.

However it seems that Yast doesn't observe the no_proxy setting, instead
using the proxy server to access the internal sites.

My install source for OES is an HTTP server that I do not want to be
accessible via the proxy, yet the access logs for that server show
requests from the proxy server and not the OES server.

Googling for +yast +no_proxy suggests that this is a bug that has
existed since, at least, SUSE 7.x! Please can it be fixed!?

I've tried setting no_proxy to both "localhost,,.<mydomain>"
and "localhost,, .<mydomain>" (ie. with spaces after commas)
as well as to just ".<mydomain>" but it makes no difference.