This is getting ridiculous. I had ZERO problem in the past getting mysql
up and running under Debian but under OES, of course it's a different
story :-<

So I installed mysql 4.0.18 from YaST onto my OES SP1 server (see other
thread of related problem). Now IDM JDBC driver recommends innodb so I
simply uncommented the innodb lines from the /etc/my.cnf file and
relaunched the mysqld daemon. Of course, it didn't work!

I checked the /var/lib/mysql/mysqld.log and got the following:

/usr/sbin/mysqld: ERROR: unknown variable

What? I then ran 'mysqld --help | grep inno' to see what innodb command it
supported and got:

--skip-innodb Don't use Innodb (will save memory)

What? Only these two? I then ran 'mysqladmin --skip-innodb' to see its
value and got:

mysqladmin: ERROR: unknown option '--innodb'

What the heck?

Here's the [mysqld] innodb section of the my.cnf file (Like I said, I only
uncommented the lines and the /var/lib/mysql directory exists).

# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = /var/lib/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /var/lib/mysql/
innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

Help! Thanks.