I have upgrade a NW6.5sp2 server to nw6.5sp3. I have also upgraded to
imanager 2.5 and downloaded the OpenWbem files for Health Monitoring. I
cannot get it to load.

When I send the command openwbem it says owcimond loads OK. The logger
shows: Using config file: /system/cimom/etc/openwbem/openwbem.conf [1]
CIMOM beginning startup. When I do m *owcimomd it is in fact not loaded.

However the log file shows a certificate error pasted below. I do not see
hostkey+cert.pem in the
path /system/cimom//etc/openwbem/hostkey+cert.pem. I have tried to run
owgencert but it says the file cannot be found.

Any ideas??

[1]safeLibCreate::create failed getting function pointer
to "createProviderIFC" from library
[1]Unable to load ProviderIFC library libnpiprovifc.nlm
[1]NetWareAuthenticator: Initialized. authentication is now functional.
[1]dlSharedLibraryLoader::loadSharedLibrary dlopen returned NULL. Error
is: (dlfcn) No such symbol was found.
[1]CIMOM failed to load indication rep layer
library /system/cimom//lib/openwbem/libowindicationreplayer.nlm
[1]HTTP Service: Error initializing SSL: Couldn't read certificate
file: /system/cimom//etc/openwbem/hostkey+cert.pem
[1]* EXCEPTION CAUGHT IN CIMOM MAIN!
[1]* OW_SSLCtxMgr.cpp: 541 SSLException: Couldn't read certificate
file: /system/cimom//etc/openwbem/hostkey+cert.pem
[1]safeLibCreate::create failed getting function pointer
to "createProviderIFC" from library
[1]Unable to load ProviderIFC library libnpiprovifc.nlm
[1]NetWareAuthenticator: Initialized. authentication is now functional.
[1]dlSharedLibraryLoader::loadSharedLibrary dlopen returned NULL. Error
is: (dlfcn) No such symbol was found.
[1]CIMOM failed to load indication rep layer
library /system/cimom//lib/openwbem/libowindicationreplayer.nlm
[1]HTTP Service: Error initializing SSL: Couldn't read certificate
file: /system/cimom//etc/openwbem/hostkey+cert.pem
[1]* EXCEPTION CAUGHT IN CIMOM MAIN!
[1]* OW_SSLCtxMgr.cpp: 541 SSLException: Couldn't read certificate
file: /system/cimom//etc/openwbem/hostkey+cert.pem