Unless someone's going to tell me there is a really good reason for it, I
find it a bit confusing that NLMs do not get automatically updated when a
service pack is installed. Why do I need to manually copy over newer NLMs
for Apache etc?

My understanding is to activate the mew iManager for example, I need to
de-install it and reinstall it, but I am not sure if I need to manually
point the installer to the service pack files etc. It's all a bit vague and
confusing. It would be far nicer to have the options during the SP install
to choose which applications you want to renew.