NW 6.5 SP5 server with NSS volumes. I am getting the op-lock error on the

Station x (task #) timed out waitng for an op-lock on file held by station #.

Found the workaround is to add the 2 commands in autoexec.ncf:

set level 2 oplocks enabled=off
set client file caching enabled=off.

Also found TID saying to disable op-lock on client.

The comment on the cool solution said it would cause other problems if turn
off op-lock support on the server. What kind of problem would I run into? I
have not received complaint from users at this point so I am not sure if
something that I should be concerned with.