I am trying to get rsync working between 2 NW 6.5 servers and it will
start to sync and after 10-15 minutes then it generated the following
error and quit:

On the Rsync server:
SendBuffer: Error fd=78 peer socket closed
error in socket IO (code 10) at io.c (1898)

On the client server:
error in socket IO (code 10) at io.c (1898)

I then reduced the --bwlimit from 10000 to 8000 and it would sync for a
bit longer and then generated same error as above and quit. I will try to
find a bwlimit that works between the 2 servers (on different subnet
connected via VPN).

Any other suggestion?

Also, I would like to know how rsync determine if a file should be sync.
Before I ran the rsync command, I used Windows Explorer to copy the
SYNCDATA folder to the rsync server and the date & time stampe & file size
between the 2 folders are identically. However, rsync still sync all files
in the folder (even I have copied the file to destination. When I repeat
the rsync command with different bwlimit parameter (due to the above
about), I noticed it skip the files and folders that was sync OK

Any clarification would be appreciated.