My 8 NW servers have the Nici 2.6.8 and eDir

As I understand it, I must upgrade my servers to 6.0.5 before I can go to

My question is, can I upgrade my certificate/timesync server to 6.0.5
then take it to 6.5.4a OR must I take all my 6.0.3 servers to 6.0.5
before taking the first one to 6.5.4.

Many thanks for the comments.