OK, tell me again why I need SLP or what does it do?

I'm trying to get SLP cleaned up on our production network. We are
having strange login issues. One user can login and one user can't. This
only happens on XP sp1 boxes. Both computers are on the same switch and
both were created with the same image. This scenario is happening all
over the district with a handful of computers.

We started out with an eight 6.0 sp3 servers. Over the summer all
servers were updated to 6.5 sp3. On 6.0 we had a Default SLP setup. In
our SLPDEFAULT container we had a Default scope. In the root of our tree
we had a FS1_V2SLPDA. This server was also the master replica.

After the upgrade to 6.5 sp3 we created a new named scope in the root
and made a new DA, BLUE1_V2SLPDA. The old scope and DA was still in the
tree and active.

I realize I can't have two scopes in our tree and shouldn't have two DA
for our network. Both are showing different services. Which one do I
remove? Do I just remove both and start over? If I do what impact will
the have on the network? Will all of the services reregister with the
DA.? I have read TIDs 10024950 What is SLP, 10027163 Configuring SLP
for a Netware server, 10059981 Configuring SLP with a SCOPED directory
agent, 10062474 SLP Design and Implementation Guidelines and 10014396
SLP Terms and Configuration references.

But from the tests below I'm now more confused and I'm still having
problems in the production network.

In my test environment of VMWare Workstation I created an OES sp1
Netware server, an XP sp1 workstation and NLD 9 desktop. I ran SLPDA on
the OES Netware server and chose the default setup. At the console I ran
display SLPDA and received Active: 0 Inactive: 0. However, when I ran
display SLP services I see 9 services running. From the XP sp1
workstation I am able to browse the tree and choose a server from the
advance tab of the client. Likewise from the NLD 9 with the Novell
client installed I'm able to login and browse the network services. Does
being able to login and see the tree prove SLP is working? Even though
it shows 0 active and 0 inactive.

OK, now for the really weird part. I deleted both the default scope and
the DA in my test network. You would think this would have broken SLP.
IT DIDN'T. If I run display SLP services it still shows the same
services and I'm still able to login and browse the tree with both clients.

Tell me again why do I need SLP?

Thank you in advance for any assistance.