I am running sp3 with the post sp3 patches. I was think of updating to
sp5, anything I should know? If my server is running , is there any
reason to update the sp level?

Thanks in advance,
HT