Which patch do i need for my Post Netware 6.5 SP4a?

If I apply eDirecty 8.7.3.7 patch, will my other 5.0 server communicat or
will it have a problem?

Any help?

Thanks