On two of my Netware servers that run NDPS 3.01q and Apache 2.0.54,
apache seems to be leaking memory at about 25mb/day. 2.0.54 seems to
have a number of leaks in it fixed by the latter versions. I've found
tids that say you can upgrade it on its own, but that its not recommended
because it may not work with other netware components/modules. That
recommendation was 4 years old.

What is the verdict today, do I need to upgrade the whole service pack in
order to solve this problem?

Also, what files do I need to be mindful of when upgrading? http.conf
for sure, but what others for iprint and such?