I am hoping someone may have heard of this issue and can help me out.

First, I have done multiple Netware 6.0 SP5 to Netware 6.5 SP4 / SP5
upgrades now, but I have this issue that seems to happen only on HP DL380 G3

Background: This is in an EMC SAN Environment, using Qlogic HBAs, using
Direct attached storage for the Dos and SYS partitions, and the SAN for data

I start the upgrade from the Netware 6 GUI, all the files copy, but on a
restart, after the driver portion the installation tells me it can't mount
SYS volume. Using NSSMU I can't see any pools on the HP Array controller.
I see the partition, but shows up with no pools. I can see the SAN luns /
partitions / pools / volumes. Just not any pools / volumes on the direct
attached storage.

If I boot from the nwserver.old directory (NW6) I can see all the pools /
volumes just fine.

I did get one server to fix by building an identical DL380 G3 box,
installing it with Netware 6, Move DS over to the new box, then upgrade to
6.5. So I have tried that on another box, assuming it may be an old NetWare
5.x or earlier Netware 6 issue. But after the upgrade, I did restore the
SYS volume, waited a month, tried the upgrade and once again it failed.

Not sure if it is corrupt files on the SYS volume, and if so why Netware 6.5
doesn't replace them, or why it would change the partition, etc.

To complicate matters, I can not duplicate the issue in a Lab environment.
I rebuild a DL380 G3 box with NetWare 6.0, and upgrade and it goes great. I
build it the same way, making me think it is something on the SYS volume
during the restore, but on multiple servers? And Only on servers running
the DL380 G3 series? In the LAB I don't use the EMC, SAN so maybe the
powerpath.cdm? Because of the SAN, EMC recommends not using the CPQSHD.CDM
on Netware 6, so is the SCSIHD.CDM breaking it? But all the EMC stuff is
running on other servers that have upgraded with no issue.

Any ideas on a solution would save me hours worth of time.