I've got a server with NetWare 6.0 and BMEE v3.5

Do I upgrade to NW 6.5 first and then to BMEE v3.8?

Or BMEE first and then NetWare?

Thanks!