I had NSEARCH running happily and had to change a hostname IP address,
which happened to be the name of the VSS: host.domain.com where host was, and it was changed to .94 for various reasons, and the
search host name needed to change.

Web search would no longer work. I changed the hostname in novonyx web
service, I made sure all apache references used the new host name, but
VSS kept insisting that the server hame was the original host name.

I tried creating anew VSS with the new hostname at the original address.
The search config applet said it was already created.

A search of novonyx, apache, tomcat, nsearch and webapps folders showed
no instance of files containing the original hostname. I could find nDS
object to modify.

So I deleted the VSS, and then tried adding a new instance with the new
host name. It still said it was already created. So I unloaded apche,
tomcat and novonyx and the reloaded.

Now when I load NSWEB I get this error:

Exception in thread "main" java.lang.NoClassDefFoundError:

java: Class com.novell.application.ServletGateway.Server exited with
status 1
There seems to be a problem loading the Java portion of the Servlet
Please execute the following command line and resolve any errors:


(running SGJINIT merely gives the same error.)

And when I try to run the search config applet, I get:

Search Error 500
java.lang.NullPointerException: at
com.novell.search.Admin.AdminServlet.showSiteList( Unknown Source) at
com.novell.search.Admin.AdminServlet.doPost(Unknow n Source) at
com.novell.search.Admin.AdminServlet.doGet(Unknown Source) at
com.novell.search.Server.GenericServlet.service(Un known Source) at
javax.servlet.http.HttpServlet.service(HttpServlet .java) at
org.apache.tomcat.facade.ServletHandler.doService( ServletHandler.java:574)
at org.apache.tomcat.core.Handler.invoke(Handler.java :322) at
org.apache.tomcat.core.Handler.service(Handler.jav a, Compiled Code) at
org.apache.tomcat.facade.ServletHandler.service(Se rvletHandler.java:485)
org.apache.tomcat.core.ContextManager.internalServ ice(ContextManager.java,
Compiled Code) at
org.apache.tomcat.core.ContextManager.service(Cont extManager.java,
Compiled Code) at
org.apache.tomcat.modules.server.Ajp13Interceptor. processConnection(Ajp13Interceptor.java,
Compiled Code) at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(P oolTcpEndpoint.java,
Compiled Code) at
org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java,
Compiled Code) at java.lang.Thread.run(Thread.java:479)

Sigh. Any suggestions? I find nothing useful in the KB searching on a
variety of keywords contained in the above.


Ken McLeod
The Delphian School