I have Netware OES 6.5 SP4a installed. I need to install sp5

Is it safe to install the sp5 update 1 since it is still in beta?

Also do I have to unload the Java before I install the Sp5.

I am running edir Do I have to update the edir or no?