I colleague upgraded a NetWare server from 5 to 6.5 some time back. It
seemed to work ok, but I've never been entirely convinced about it -
occasional slow response times, etc

During a ZenWorks 7 upgrade, I noticed that the ZenWorks install reported
this server as version 5

On investigation, I found that the Version number for the server object in
ConsoleOne is reported as Novell NetWare 5.00.09[DS]

6.5 SP2 is listed in the list of available products on this server, so I'm
confident 6.5 was installed and is running (so is my colleague).

Should I be worried about this (I am) or is this field just a descriptor
that could be safely ignored? Should I reapply SP2 to be on the safe side?