I have just upgraded to SP6 an Networker 7.2.1
I've been told that I should also apply TSA5UP19 patch.

The date for the patch is older than SP6 so in my way of thinking it should
be included in SP6

Should I apply TSA5UP19 patch or will I downgrade the server if I do?