Did an inplace upg from 60sp5 to OES 65sp5 (overlay CD). Have run post
sp5 upds. When server comes up PSCORE.NLM, and PSCL.NLM are flagged red
as unresolved. Following is how it shows in the logger.txt file:
______
Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003
Module PSCORE.NLM load status PUB EXISTS
SERVER-5.70-918: Loader cannot find public symbol: IPSUnknown_AddRef for
module PSCL.NLM
(a bunch of these "cannot find public symbol" appear)

--It then continues like this:

Module PSCL.NLM load status UNRESOLVED
Auto-Loading Module LEGACYLM.NLM
Auto-loading module LEGACYLM.NLM
Legacy License Manager
Version 8.50 October 29, 2003
Copyright (C) Pervasive Software Inc. 2003
Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Module PSCORE.NLM load status PUB EXISTS
Auto-Loading Module PSCL.NLM

Auto-loading module PSCL.NLM

Pervasive Services Class Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Module PSCORE.NLM load status PUB EXISTS
Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Module PSCORE.NLM load status PUB EXISTS
SERVER-5.70-918: Loader cannot find public symbol: IPSUnknown_AddRef for
module
PSCL.NL
(a bunch of these "cannot find public symbol appear)

--It then continues like this:

Module PSCL.NLM load status UNRESOLVED
Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Module PSCORE.NLM load status PUB EXISTS
Auto-Loading Module PSCL.NLM

Auto-loading module PSCL.NLM

Pervasive Services Class Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003

Module PSCORE.NLM load status PUB EXISTS
Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003
Module PSCORE.NLM load status PUB EXISTS
Auto-Loading Module PSCORE.NLM

Auto-loading module PSCORE.NLM

Pervasive Services Core Library

Version 1.50 October 29, 2003

Copyright (C) Pervasive Software Inc. 2003
Module PSCORE.NLM load status PUB EXISTS
SERVER-5.70-918: Loader cannot find public symbol: IPSUnknown_AddRef for
module PSCL.NLM
(a bunch of these "cannot find public symbol appear)

--It then continues like this:
Module PSCL.NLM load status UNRESOLVED
Module LEGACYLM.NLM cannot be loaded until PSCORE is loaded

Module LEGACYLM.NLM cannot be loaded until PSCL is loaded

Module LEGACYLM.NLM cannot be loaded until PSCORE is loaded

Module LEGACYLM.NLM cannot be loaded until PSCL is loaded
Module LEGACYLM.NLM load status AUTO FAIL

SERVER-5.70-1590: Symbol already defined: ucmgr_requestlicense
SERVER-5.70-1590: Symbol already defined: ucmgr_releaselicens
SERVER-5.70-1590: Symbol already defined: ucmgr_getuc
SERVER-5.70-1590: Symbol already defined: ucmgr_gettimebombmsg
SERVER-5.70-1590: Symbol already defined: ucmgr_gettimebomb
SERVER-5.70-1590: Symbol already defined: ucmgr_getcurusercountinfo
SERVER-5.70-1590: Symbol already defined: ucmgr_display_err
SERVER-5.70-1590: Symbol already defined: ucmgr_close

Error processing Public Records.

Module ENGINELM.NLM NOT loaded
Module ENGINELM.NLM load status PUB EXISTS
Loading module NWMKDE.NLM
This module is ALREADY loaded and cannot be loaded more than once.
Module NWMKDE.NLM load status NOT MULTIPLE
Loading module BTRIEVE.NLM
This module is ALREADY loaded and cannot be loaded more than once.
Module BTRIEVE.NLM load status NOT MULTIPLE
Loading module NWBSRVCM.NLM
NWBSRVCM.NLM v7.90.000, Build 230

Version 7.90 March 20, 2001
Module NWBSRVCM.NLM load status OK
Loading module PORTAL.NLM
This module is ALREADY loaded and cannot be loaded more than once.
Module PORTAL.NLM load status NOT MULTIPLE
Btrieve Communications Manager 7.90.230.033

Copyright (C) Pervasive Software Inc.2001

All Rights Reserved.

(It continues to load other modules ok)
_________


Q. Is this a problem with btrieve?
I think before upg it was running CA brighstor v11.x and loading btrieve
v8.50. After the OES upg it now shows running v7.90. How to fix this?
reinstall brighstor and update btrieve?

Please advise.
thanx
Haydee