Here's hoping someone can help me with this--I'm at my wits' end! And
meanwhile we're not getting backups.

I have been using a Seagate DAT (DDS4-compatible) tape drive for a few
years, with Maxell DDS4 tapes, connected to an Adaptec 29160N SCSI card.
It's been working great for years. I have a 3-week cycle of 15 tapes,
and I discard (or archive) them after a year or 2. And I run a cleaning
tape every 2 weeks. This is under NW6.0SP5, using BackupExec 9.1.

A couple of months ago I started getting "bad media" errors, or some
other read/write errors, with increasing frequency, until the backups
would not complete successfully at all. I came to understand that
Quantum had bought out Seagate's tape drive business, and were
contracting the tech support to Certance. I called and they helped me
with it, finally concluding that it needed repair/replacement. They
offered an out-of-warranty replacement for $210, which I jumped at. It
arrived and I installed it in place of the old drive. I immediately did
a test backup job, which failed with an error similar to the previous
ones. That was a clue as to the troubles that were just beginning, but I
chose at that point to believe that the previous drive had damaged the
tapes I had been using. So I grabbed a brand-new tape I found nearby and
did another test backup to it. It worked fine. So I left that tape in
place and let it do the regular nightly backup. It worked fine. But the
next day I just happened to notice that the "brand-new" tape I had
grabbed was not a DDS4 tape but a DDS3. So I put in a brand-new DDS4
tape for a test backup. Failed. Tried another. Failed. I tried a number
of my used DDS4 tapes. All failed. The error message in each case was
"foreign media detected" or "blank media" or "the tape drive is having
problems reading data".

I called Certance again and they were no help. I called Symantec
(Veritas), where we have a support contract for BackupExec, and the guy
was much more helpful, sending me some diagnostic utilities in an effort
to see what was going on. We came to the conclusion that the tapes were
bad. They were all from the same batch of tapes I purchased last August.
Perhaps the whole batch was bad. (Which doesn't explain why they had
been working fine for me until just recently...) In accordance with that
theory, I retrieved an archived tape from years ago (also a DDS4), and
put it in and ran a test backup. It worked. So far, the theory is
holding up. So I left that tape in to run the regular nightly backup.
This morning, guess what I found? It failed! Here's the BE error message
in its entirety:
Error on HA:0 ID:4 LUN:0 SEAGATE DAT 9SP40-000.
An error has been detected during this operation that indicates
that part of the media may be damaged. This media should not be
used for any additional backup operations. Data on this media
prior to the damaged section may still be restored.
Possible corrective actions for this error are:
1.) Use different media
2.) Clean the media drive
Product: DAT 9SP40-000
Firmware: 910B
Function: Write(5)
Error: Media failure(3)
Sense Data:
70 00 03 00 - 00 00 00 0a - 00 00 00 00 - 03 02 00 00
00 00 00 00 - 00 00 00 00 - 00 00 00 00 - 00 00 00 00

So I'm at my wits' end here. What is going on?!? Bad tapes? Bad
replacement drive? Bad SCSI card? EMP? ;) Any ideas where I should turn
next? Thanks in advance for any help--double thanks if you can solve the
problem!!! - JR