Today I encountered a problem with the file system trustees on a NSS volume
while moving folders with Windows Explorer.

I created a new folder in the root of the volume and I moved 3 existing
folders from the same volume in it. Since the move, the users couldn't
access the moved folders. I checked the trustees via the properties windows
of Windows 2000 and all the trustees are still there.

But, if I go in Console One and open an object (user group) who has rights
to one of those folders and check via the Rights to Files and Folders tab
(show... then select the volume), I see no rights. I tried to manually add
the rights and I have a message saying that "This trustee is already
assigned in the list for the selected object."

I ran DSrepair and saw no errors.

The only way to restore those rights is to go in the property window of the
folder via Windows 2000 and remove the rights, click apply, close the
window, open the window again and then set the rights and apply again. If I
just remove, apply, add and re-apply it doesn't work.

I found TID 10080568 and it says that the issue was resolved with nw6 sp3a
and NSS updates of july 2003... We have NW65SP3 with NSS updates of june
2005, so it should be corrected, no?

Can someone help me on that?

Workstation :
Windows 2000 Pro - SP4
Netware client
ConsoleOne : 1.3.6d

Server :
NW65 SP3 (CPR Release)
SP revision 3
Server Version 5.70.03 (may 23 2005)
eDir version SMP
NDS version 10551.78 (jan 22 2005)
NSS version 3.22 (june 7 2005)