Just got confirmed through an incident via Novell.

If you are ( like we were...) using Mylex Raidcard's of their last
revisions ( Acceleraid 170/352 or Extremeraid 1100/2000/3000), then
the upgrade to SP4 of NW 6.5 WILL stop your server.

This regardless off firmware, bios, driverversion.
Novell found through coredumps that "new" functions in SCSIHD.cdm in
SP4 will make the driver break out to the debugger.

According to Novell, they are not maybe new functions,, but have not
previously been used ( and difference is..??...)...,,,

Anyway, workaround for the time beeing is to back-rev scsihd.cdm.