Our Server in Paris went down on Tuesday 27th December. When restarting it
got to

Slot 0 - Smart Array 5i+ Controller 64Mb

1792 - Slot 0 Drive Array - Valid data found in Array Accelerator
Data will be automatically written to drive array

1729 - Slot 0 Drive Array - Disk performance optimisation scan in progress
Raid 4/5 ADG performance may be higher after completion

1721 - Slot 0 Drive Array - Drive parameter tracking predicts imminent
The following drive(s) should be replaced when conditions permit:
SCSI port 1 SCSI IDs 2,3

Then startup hangs up at services loading ; and console command is not

We then noticed that 2 of the drives in the RAID 5 Array (total 4 drives)
had Red flashing lights and the above error about imminent failure. We got 2
new drives shipped to them which they received today. We replaced one drive
and did the rebuild - Fine. Replaced the 2nd drive and did a erbuild - Fine.

However when booting up we get the following message and the server then

Module MALHLP.NLM loaded status OK

NSS background checking scheduled

Deactivating pool "SYS"...

Deactivating volume "SYS"...

Dismounting volume "SYS"

29 Dec 2005 6:18pm NSS<COMN>-3.02-xxx: comnPool.c[2481]

Pool SYS: System data error 20012(myBTree.c[96]). Block 599134(file
block(599134)(ZID 5)

Adding swap file to 'SYS'

Dismounting Volume SYS

CCS.NLM: Initialization waiting for XMGR. (0 sec.)

Loading module PMLODR.NLM

Portions (C) Copyright...

Loading module POLIMGR.NLM

Netware licence...

Module POLIMGR.NLM load status OK

NICI CSS: FATAL - Initialization error.

Controlled cryptography services are not available

When booting up using -NS -NA -NL then run startup.NCF

Loading Module IDECD.CDM [OK]

Loading Module CPQRAID.HAM [OK]
Interrupt assignment: 57 (Device driver is HIN aware.)

Loading Module IDEATA.HAM [OK]
Interrupt assignment: 14

Loading Module ADPT160M.HAM [OK]
Interrupt assignment: 96 (Device driver is HIN aware.)

Loading Module ADPT160M.HAM [OK]
Interrupt assignment: 112 (Device driver is HIN aware.)

list devices
0x0001: [V504-A0-D0:0] Compaq Smart Array 5i Slot 0 ID 0 LUN 0
0x0003: [V025-A1-D0:0] COMPAQ CD-ROM SC-148C B101
0x000C: [V321-A2-D6:0] Unbound Device Object

nss /poolverify
Loading Module NSS.NLM [AUTO FAIL]
Auto-loading Module NSSWIN.NLM [OK]
Auto-loading Module LIBNSS.NLM [OK]
Auto-loading Module LOCNLM32.NLM [OK]
Auto-loading Module UNICODE.NLM [UNRESOLVED]
Auto-loading Module UNICODE.NLM [UNRESOLVED]

It is on Loadstage 1 that the server kills over - when trying to mount the
SYS volume. The problem is that the last good backup was on the 8th of
December according to our records so I would ideally not like to rebuild the

The server is running NW6 SP2 and Groupwise 6.5.4.

We have tried Vrepair but no volumes are found.

Have tried nss /poolrebuild but no pools found.


1. Is there a way to repair this?

2. If not is there a way to only rebuild the SYS volume only so we do not
lose data?

3. If all fails we will need to rebuild. What is the best method for
restoring Groupwise? Reinstall Groupwise on the server and then restore the
files into GWPO and GWDOM directory?

Many Thanks