I have a really weird one!

I am also unsure of where this post sits so I will try it here!

I am running Win2000 Pro with latest NW client 4.91SP2.

A while ago, when I was planning my upgrade from Novell 4.1 to 6.5 (with new
servers and installation, not a migration), I had copied various bits and
pieces from the 4.1 server for reference. I have just noticed that in my
C:\temp folder, I still have a public folder from the old server, with all
the usual sub folders and files inside. If I try to delete this I get cannot
delete audwin16.dl_ Access is denied. The source file may be in use.
I have tried rebooting in to safe mode and doing the same, but get the same
error. I don't think the file name is significant, it is merely trying to
delete the first file in alphabetical order, as I get the same error for any
other file (showing that particular file name).
If I check the attributes to the files / folders they are not read only,
and I have tried making them read only and then making them not read only
with the same results. So basically, I am stuck with this folder and bunch
of files. They seem to be permanently etched on the hard disk's surface!