I have been using snapshots as part of my backup process for a little while
now. This is on a NW6.5 sp4a server. I run the following batch file prior
to backup:

?mm snap delete main_pool_s1
mm snap create main_pool Ark_pool main_pool_s1
mm snap activate main_pool_s1
mount apps_sv
mount data_sv
mount test_sv
mount storage_sv

mm snap delete sys_s1
mm snap create sys Ark_Pool sys_s1
mm snap activate sys_s1
mount volume sys_sv

And then I run this batch file after the backup:

mm snap delete sys_s1
mm snap delete main_pool_s1

The mm snap delete commands in the batch file for before backup are there to
make sure that there isn't already a snapshot in place. Normally there is
no snapshot to delete so this simply returns an error. Last night the
process hung up on the mm snap delete main_pool_s1 command. The console
screen showed "deactivating main_pool_s1" but never continued from there,
and never returned a command prompt. I attempted to down the server from an
alternate console screen, but the process hung part way through, so I had to
manually power of and back on. I performed a pool rebuild on Main_Pool and
Ark_Pool, but when I ran the batch file it hung again. I again had to
manually power off / on the server. I ran the pool rebuilds again. I then
created the snapshots of the Sys pool and Main_Pool without the delete
command first. This worked and I was able to mount all the snapshot
volumes: sys_sv, apps_sv, data_sv, etc. I then performed the snap delete
commands. Sys_s1 was deactivated properly. The volumes in Main_Pool_s1
were dismounted properly, but once again the process stalled when it was
deactivating Main_Pool_s1. Once again I had to power off / on the server to

Is this a problem in the MM module? Do I have an underlying hardware issue?
How do I figure out what is wrong with my server?

Your help is appreciated,

Brad Johnson