We have three Proliant ML530 servers with Smart Array 5300 controllers
running NW6.5 SP5.

One of these three servers has a problem with CPQSHD.CDM. When we installed
SP2 on this server it came up with no pool or volumes at all. We found it
worked ok with SCSIHD.CDM and used that instead. However we recently
installed an HBA running QL2X00.HAM into the server, for san connectivity to
an EVA5000, and found that we needed CPQSHD.CDM to properly see the san
drives. However if the server boots up using CPQSHD.CDM I get no local
drives. If I boot with SCSIHD then load CPQSHD I can see the san drives
using LIST DEVICES and all seems well until I scan the san device (HSV110)
for partitions in NSSMU, which seems to immediately cause the SYS pool to
deactivate with "pool integrity violated" type errors.

I was able to resolve this catch-22 by backrevving to CPQSHD.CDM v1.59 dated
28th May 2003, which is (I believe) the pre-SP2 version. The current SP5
version is v2.06 dated 7th Nov 2005. I tried CPQSHD v2.06 and v2.02 with the
same problem. The only one I haven't tried is v2.00 dataed 13th Oct 2003.

I'm concerned that this driver is significantly older than the others and
may cause issues working with more recent hardware drivers, and I can't
understand why one Proliant ML530 server has this problem and the others
(identical hardware) don't. Also this is very probably going to remain a
problem with future support packs.

Can anyone suggest how I might troubleshoot this? I can't find anything
relevant on the Novell/HP support sites.


Steve Law