I have the following configuration:

HP MSA1500 SAN controller
HP MSA30 drive bay
HP fiber SAN switch
HP DL380 server running Novell Netware 6.5.

All of the netware volumes except for SYS are on the SAN. Now, I also
have a few Windows 2003 servers connected to the SAN switch. (There
is a second array on the SAN formatted as a Windows partition). I use
it for random Windows file storage. It has worked well this way for
years. I decided that I wanted to cluster two of the Windows boxes
connected to the SAN. When I run the Windows cluster administrator,
it recognizes the SAN as a shared storage device, as I expected.
However, before the cluster creation wizard finishes, the SAN dies.
It forceably dismounts all the netware volumes. Then, the Windows
cluster administrator errors out.

In my Netware logs, this is what I see:
3-01-2007 8:13:15 pm: CPQSHD-2.6-0
Severity = 3
CPQSHD: The COMPAQ MSA1000 VOLUME 500508B300908C60 (4.82)
disk device returned a non-supported SCSI status of 18h on
a completing I/O request. This device will be deactivated.

The only way to make the Netware server remount all the volumes on the
SAN is to reboot the box. If I type 'mount all' the console locks
up. I have no idea why Netware and Windows work well together on the
SAN until I try to cluster two of the Windows boxes. Does anyone have
any ideas?