Yes, another one :)

I'm having all sorts of fun trying to get two brand new servers working
in our Citrix PS4.0 farm. I'm sure it's more of a Novell client problem ...

I've got 2 servers that work perfectly. We've got Active Directory
synced with eDir using DirXML - usernames and passwords are the same on
both directories. Logging in to Citrix is usually through the NW Client
(v4.91), which then does an AD login afterwards. We've got roaming
profiles, held on a seperate Windows server. There's no farm-level
integration with eDir - apps are associated with AD users and groups. I
though I knew all there was to know about chaining the NWGina/CtxGina
DLLs, but ..

I just can't get it working with the two new servers. There's absolutely
nothing different about them - same OS (Win2003 Standard), same
hardware, same everything. The GINAs are configured like this:

HLKM\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
GinaDLL: CtxGina.dll
CtxGinaDLL: NWGina.dll

With this configuration, I get two errors when logging in. Let's say I
log in as JBloggs:

Windows cannot copy file \\profileserver\profiles\SomeOtherUser to
location C:\Documents and Settings\JBloggs\SomeOtherUser. Possible
causes of this error include network problems or insufficient security
rights. If this problem persists ... etc


Windows cannot find the local profile and is logging you on with a
temporary profile. Changes you make to this profile will be lost when
you log off.

"SomeOtherUser" is a username of .. er .. some other user, who never
logs into Citrix! I've no idea where it's picking this up from. It seems
like it's making the authentication to eDir fine, but isn't passing
through the correct AD details. I get logged in with a TEMP profile.

If I change CtxGinaDLL to the standard MSGina.DLL, it logs in fine,
profiles and all ... but I'm then prompted to log into NetWare - it
doesn't pass thru the password to the NW Client.

To stress again: this is working on two other servers with no problems.
I've replicated all the relevant registry settings that I can find.

I hope I've been as clear as possible; can someone please suggest what
I've done wrong?