I have 250+ 4.90sp1a -based workstations and now all of a sudden I've
noticed a few (including a brand new install from a campus agreement XP-SP2
CD) now have a problem where you can no longer delete folders you've just
created on a (NSS) volume (NW6.0), *in Explorer*. Even after a reboot,
believe it or not, you can't delete that folder on the workstation it was
created - go to a different workstation without this affliction and the
folder can be happily deleted in Explorer.

I say "in Explorer", because even more bizarre is that on the afflicted
workstation, you can drag the stubborn folder to the recyle bin or RD it
from a shell window.

I've spent a lot of time on it, trying to isolate the cause, methodically,
and just couldn't find any software or system setting that could cause it.
I also came to believe installing 4.91 fixed it, which it did on my clean
XPsp2 system. However, a couple days ago I was updating an old system
image and the affliction suddenly appeared on that workstation as well, so
I installed client32 4.91. Unfortunately, now I found that even doing that
didn't correct the problem, so now I was right back to where I was three
weeks ago.

The only TID Novell remotely close to talking about a problem like this
just had a link to a *seemingly* old Microsoft KB article (328170) which I
dismissed early on, because it claims that the problem described was "first
corrected in Microsoft Windows XP Service Pack 2".

Desperate to try anything once installing the latest (both non-beta and
then beta) Client32 didn't make the problem go away on those latest
workstations, I tried the work-around listed in Microsoft's Q328170 KB
article and BINGO it fixed the problem. When I set the registry key back
to the default, the problem came back.

- Tom