Home

Results 1 to 8 of 8

Thread: net use on XP to Novell Server

Hybrid View

  1. #1
    tina_buechner@southwire.com NNTP User

    net use on XP to Novell Server

    I cannot seem to get net use to work from our new XP Pro computers to a
    Novell server when trying to connect as a different user. We have Netware
    6sp5 and Novell Client 4.91sp2. We have always run the same command on
    Windows 2000 and it worked as long as IPX was the first protocol. Here
    is the command we use:
    net use g: \\fs1\sys /user:hrmanager

    We get the following error back:
    "System error 1219 has occurred.
    Multiple connections to a server or shared resource by the same user,
    using more than one user name, are not allowed. Disconnect all previous
    connections to the server or shared resource and try again." I look at
    the connections on the Novell server and neither the logged in user, nor
    the user in the net use command are connected.

    We get this same error on the Windows 2000 machines if IP is the first
    protocol but it works on W2K if IPX is the first protocol. I cannot get
    it to work at all on XP (yes, the firewall is turned off). Net use will
    work on XP without the /user switch but we need it to work with another
    user that we have set up to distribute files to a bunch of Novell servers.

    Can anyone tell me what to do to get this to work.
    Thanks,
    Tina

  2. #2
    craig wilson NNTP User

    Re: net use on XP to Novell Server

    Try - "net use g: \\fs1\sys /user:.hrmanager.hr.acme"

    > net use g: \\fs1\sys /user:hrmanager




    --
    Craig Wilson
    Novell Product Support Forum Sysop
    Master CNE, MCSE 2003, CCN

  3. #3
    tina_buechner@southwire.com NNTP User

    Re: net use on XP to Novell Server

    I tried that too and get the same error.
    Tina


    > Try - "net use g: \\fs1\sys /user:.hrmanager.hr.acme"
    >



  4. #4
    craig wilson NNTP User

    Re: net use on XP to Novell Server

    Sorry, I just reread your message.

    This is working as designed or "failing as it is designed to fail"
    depending on your point of view.

    You can only be authenticated to the NDS Tree once.

    The error message you are seeing indicates that somebody is already
    authenticated to the tree.

    It is not possible to authenticate to two different servers in the same
    tree as two different users w/o third party software or some real good
    tricks with process ownerships.

    tina_buechner@southwire.com wrote:
    > I tried that too and get the same error.
    > Tina
    >
    >
    >> Try - "net use g: \\fs1\sys /user:.hrmanager.hr.acme"
    >>

    >



    --
    Craig Wilson
    Novell Product Support Forum Sysop
    Master CNE, MCSE 2003, CCN

  5. #5
    tina_buechner@southwire.com NNTP User

    Re: net use on XP to Novell Server

    Okay, I am starting to get confused. We can still use the net use command
    with the /user switch on W2K PC's if IPX is the preferred protocol but it
    won't work on XP PC's anymore. What has changed? Was it using bindery
    and bindery is no longer supported?
    Could you please clarify?
    Thanks,
    Tina

    > Sorry, I just reread your message.
    >
    > This is working as designed or "failing as it is designed to fail"
    > depending on your point of view.
    >
    > You can only be authenticated to the NDS Tree once.
    >
    > The error message you are seeing indicates that somebody is already
    > authenticated to the tree.
    >
    > It is not possible to authenticate to two different servers in the same
    > tree as two different users w/o third party software or some real good
    > tricks with process ownerships.
    >
    > tina_buechner@southwire.com wrote:
    > > I tried that too and get the same error.
    > > Tina
    > >
    > >
    > >> Try - "net use g: \\fs1\sys /user:.hrmanager.hr.acme"
    > >>

    > >

    >
    >
    > --
    > Craig Wilson
    > Novell Product Support Forum Sysop
    > Master CNE, MCSE 2003, CCN



  6. #6
    Joseph Marton NNTP User

    Re: net use on XP to Novell Server

    On Wed, 14 Jun 2006 18:12:02 +0000, tina_buechner wrote:

    > I cannot seem to get net use to work from our new XP Pro computers to a
    > Novell server when trying to connect as a different user. We have Netware
    > 6sp5 and Novell Client 4.91sp2. We have always run the same command on
    > Windows 2000 and it worked as long as IPX was the first protocol. Here
    > is the command we use:
    > net use g: \\fs1\sys /user:hrmanager
    >
    > We get the following error back:
    > "System error 1219 has occurred.
    > Multiple connections to a server or shared resource by the same user,
    > using more than one user name, are not allowed. Disconnect all previous
    > connections to the server or shared resource and try again." I look at
    > the connections on the Novell server and neither the logged in user, nor
    > the user in the net use command are connected.


    I'm not sure if this is a bug in the Novell Client or not, and I'll be
    curious what the final outcome is. But I can tell you what little I know
    (which is very little). Take Novell completely out of the mix... if you
    take a Windows client and attach to a Windows server, then try to attach
    to that same Windows server again using a different user you'll get the
    above error. You can only connect using one set of credentials. Sounds
    like the connection to your NetWare box using net use is having the same
    problems. Once you are connected as one user, the networking in Windows
    (ignore the Novell Client) isn't going to let you create a new connection
    as another user.

    Here might be another way of doing what you need. If you have ZEN, you
    can give an application object additional file system rights. It sounds
    like that's basically what you are trying to accomplish... logged in user
    doesn't have rights to certain directories, but you want to run a batch
    file to distribute files and have that batch file get access to additional
    directories. If you have ZEN you could create an app object to distribute
    these files, and then give that app object the additional rights.

    Other than that, I think in old versions of NetWare (either 3.x or 4.x)
    there was an attach command. If you can still get a copy of attach.exe
    you might then be able to use that in conjunction with map.

    Joe

  7. #7
    tina_buechner@southwire.com NNTP User

    Re: net use on XP to Novell Server

    >
    > take a Windows client and attach to a Windows server, then try to attach
    > to that same Windows server again using a different user you'll get the
    > above error. You can only connect using one set of credentials. Sounds
    > like the connection to your NetWare box using net use is having the same
    > problems. Once you are connected as one user, the networking in Windows
    > (ignore the Novell Client) isn't going to let you create a new connection
    > as another user.


    I was thinking it must be a new WindowsXP security/licensing thing but
    wasn't sure.

    >
    > Here might be another way of doing what you need. If you have ZEN,


    No, we don't have Zen.

    >
    > Other than that, I think in old versions of NetWare (either 3.x or 4.x)
    > there was an attach command. If you can still get a copy of attach.exe
    > you might then be able to use that in conjunction with map.



    Thanks Joe. I think I will just get around the problem by creating a
    group of the users with access to the directories they need to distribute
    files and just do away with using one usercode to do the process.
    I would also like to know if anyone else comes up with a solution though.
    Tina

  8. #8
    W. Prindl NNTP User

    Re: net use on XP to Novell Server

    I suspect that your XP machines are trying to establish a CIFS
    connection to your server. Try to change network provider order at the
    clients into netware to be the first and run a cifsstop at the server
    and see if that helps.

    W. Prindl

    --



    tina_buechner@southwire.com wrote:

    > I cannot seem to get net use to work from our new XP Pro computers to
    > a Novell server when trying to connect as a different user. We have
    > Netware 6sp5 and Novell Client 4.91sp2. We have always run the
    > same command on Windows 2000 and it worked as long as IPX was the
    > first protocol. Here is the command we use:
    > net use g: \\fs1\sys /user:hrmanager
    >
    > We get the following error back:
    > "System error 1219 has occurred.
    > Multiple connections to a server or shared resource by the same user,
    > using more than one user name, are not allowed. Disconnect all
    > previous connections to the server or shared resource and try again."
    > I look at the connections on the Novell server and neither the logged
    > in user, nor the user in the net use command are connected.
    >
    > We get this same error on the Windows 2000 machines if IP is the
    > first protocol but it works on W2K if IPX is the first protocol. I
    > cannot get it to work at all on XP (yes, the firewall is turned off).
    > Net use will work on XP without the /user switch but we need it to
    > work with another user that we have set up to distribute files to a
    > bunch of Novell servers.
    >
    > Can anyone tell me what to do to get this to work.
    > Thanks,
    > Tina


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •