Roaming profiles are driving me mad....... again!!!!!!!!

A few months back, I setup Roaming profiles for a group of users -
apart from speed issues, which the latest client and UPHClean fixed,
they've worked pretty well.

I've now decided that it would be useful to have a Mandatory profile
for everyone else. I did some reading, and the recommended method for
setting one up was to create a new user with a roaming profile - Tweak
that profile, then finally rename ntuser.dat to ntuser.man

That didn't sound too difficult - But as my existing roaming users have
a fairly restrictive group policy in place, I needed to setup a
completely seperate user. I created a new OU, User Group, User policy
and User and created a new folder on my profiles volume for the User's

No matter what I do, I can't make any changes to the profile. I've
tried copying someone elses profile into the new folder, and it loads
fine, so it doesn't seem to be a path issue. I've given the user full
access rights to the folder, and that made no difference.

I've tried on several differnt workstations - again, there was no

Am I missing something obvious?

Thanks in advance!