Home

Results 1 to 10 of 10

Thread: SLP/XP Firewall not working

Hybrid View

  1. #1
    John NNTP User

    SLP/XP Firewall not working

    We're running 4.9.1SP3 and I've configured SLP, and the client is configured as well (slpinfo /d) shows the DA's, etc.

    I've also allowed UDP 427 in for the XP firewall, but when the clients boot up and get the novell client, I can select the tree, but but if I click on context, I get "tree not found" or if I login, it doesn't work.

    If I put a server IP/dns name, it works - any ideas?



  2. #2
    Edison Ortiz NNTP User

    Re: SLP/XP Firewall not working

    On 12/13/2006 John wrote:

    > If I put a server IP/dns name, it works - any ideas?


    Let's see the SLPINFO /ALL


    --
    Edison Ortiz
    Novell Product Support Forum SysOp
    (No Email Support, Thanks !)

  3. #3
    John NNTP User

    Re: SLP/XP Firewall not working

    C:\>slpinfo /all


    ************************************************** ***
    *** Novell Client for Windows NT ***
    *** Service Location Diagnostics ***
    ************************************************** ***

    SLP Version: 4.91.3.0
    SLP Start Time: 2:56:55pm 12/13/2006
    Last I/O: 2:57:04pm 12/13/2006
    Total Packets: Out: 7 In: 6
    Total Bytes: Out: 298 In: 395


    SLP Operational Parameters Values
    ------------------------------- ------------
    Static Scopes YES
    Static Directory Agents YES
    Active Discovery YES
    Use Broadcast for SLP Multicast NO
    Use DHCP for SLP YES
    SLP Maximum Transmission Unit 1400 bytes
    SLP Multicast Radius 32 hops


    SLP Timers Values
    ------------------------------------- ------------
    Give Up on Requests to SAs 15 seconds
    Close Idle TCP Connections 5 minutes
    Cache SLP Replies 5 minutes
    SLP Default Registration Lifetime 10800 seconds
    Wait Before Giving Up on DA 5 seconds
    Wait Before Registering on Passive DA 1-2 seconds


    Scope List Source(s)
    ---------------------------------------- ------------
    VPI CNFG


    DA IP Address Source(s) State Version Local Interface Scope(s)
    --------------- --------- ----- ------- --------------- ---------------

    192.168.0.89 CNFG UP SLPV2 192.168.101.13 VPI
    192.168.0.103 CNFG UP SLPV2 192.168.101.13 VPI
    192.168.0.54 CNFG UP SLPV2 192.168.101.13 VPI


    Local Interface 192.168.101.13
    ---------------------------------
    Operational State: UP
    Operating Mode(s): MCAST,STATIC-DA
    SA/UA Scopes: VPI
    Last I/O: 2:57:04pm 12/13/2006
    Total Packets: Out: 7 In: 6
    Total Bytes: Out: 298 In: 395
    Last Addr Out: 192.168.0.54
    Last Addr In: 192.168.0.54



    C:\>














    "Edison Ortiz" <eortiz@nscsysop.com> wrote in message
    news:xn0eux9heidxdj005@support-forums.novell.com...
    > On 12/13/2006 John wrote:
    >
    >> If I put a server IP/dns name, it works - any ideas?

    >
    > Let's see the SLPINFO /ALL
    >
    >
    > --
    > Edison Ortiz
    > Novell Product Support Forum SysOp
    > (No Email Support, Thanks !)




  4. #4
    Edison Ortiz NNTP User

    Re: SLP/XP Firewall not working

    On 12/14/2006 John wrote:

    > 192.168.0.54


    Let's see the DISPLAY SLPDA from the server
    with the IP above.

    Also, make sure the amount of services displayed
    while typing DISPLAY SLP SERVICES on that
    server matches with the other NetWare servers.


    --
    Edison Ortiz
    Novell Product Support Forum SysOp
    (No Email Support, Thanks !)

  5. #5
    John NNTP User

    Re: SLP/XP Firewall not working

    Here it's

    VPI_SERVER2:display slpda

    SLP LOOPBACK : v2 : ACTIVE : VPI : IANA : 11 : 0ms

    Total Active: 1 Total Inactive: 0


    display slp services shows 30 items on all DA servers - thanks for helping
    us out.



    "Edison Ortiz" <eortiz@nscsysop.com> wrote in message
    news:xn0euyymc24cfd007@support-forums.novell.com...
    > On 12/14/2006 John wrote:
    >
    >> 192.168.0.54

    >
    > Let's see the DISPLAY SLPDA from the server
    > with the IP above.
    >
    > Also, make sure the amount of services displayed
    > while typing DISPLAY SLP SERVICES on that
    > server matches with the other NetWare servers.
    >
    >
    > --
    > Edison Ortiz
    > Novell Product Support Forum SysOp
    > (No Email Support, Thanks !)




  6. #6
    Edison Ortiz NNTP User

    Re: SLP/XP Firewall not working

    Looks good, if you disable the firewall - SLP works fine ?


    --
    Edison Ortiz
    Novell Product Support Forum SysOp
    (No Email Support, Thanks !)

  7. #7
    John NNTP User

    Re: SLP/XP Firewall not working

    on or off it doesn't work - although something interesting, when the FW is
    off, i can telnet to workstation to port 427.
    When FW is on, I cannot...although, I'm allowing UDP 427 in the FW exception
    list - do I need to allow TCP 427 also or something else, like NCP 524?


    "Edison Ortiz" <eortiz@nscsysop.com> wrote in message
    news:xn0ev03ih27ihh001@support-forums.novell.com...
    > Looks good, if you disable the firewall - SLP works fine ?
    >
    >
    > --
    > Edison Ortiz
    > Novell Product Support Forum SysOp
    > (No Email Support, Thanks !)




  8. #8
    Edison Ortiz NNTP User

    Re: SLP/XP Firewall not working

    On 12/15/2006 John wrote:

    > on or off it doesn't work - although something interesting, when the FW is
    > off, i can telnet to workstation to port 427. When FW is on, I
    > cannot...although, I'm allowing UDP 427 in the FW exception list - do I need
    > to allow TCP 427 also or something else, like NCP 524?


    You need TCP,UDP 427 and NCP,UDP 524.


    --
    Edison Ortiz
    Novell Product Support Forum SysOp
    (No Email Support, Thanks !)

  9. #9
    John NNTP User

    Re: SLP/XP Firewall not working

    I did, we still have the tree cannot find issue though


    "Edison Ortiz" <eortiz@nscsysop.com> wrote in message
    news:xn0ev07pz80ggb004@support-forums.novell.com...
    > On 12/15/2006 John wrote:
    >
    >> on or off it doesn't work - although something interesting, when the FW
    >> is
    >> off, i can telnet to workstation to port 427. When FW is on, I
    >> cannot...although, I'm allowing UDP 427 in the FW exception list - do I
    >> need
    >> to allow TCP 427 also or something else, like NCP 524?

    >
    > You need TCP,UDP 427 and NCP,UDP 524.
    >
    >
    > --
    > Edison Ortiz
    > Novell Product Support Forum SysOp
    > (No Email Support, Thanks !)




  10. #10
    Edison Ortiz NNTP User

    Re: SLP/XP Firewall not working

    On 12/18/2006 John wrote:

    > I did, we still have the tree cannot find issue though


    I don't think it's a SLP issue but perhaps a bad name cache issue,
    please see:

    http://support.novell.com/cgi-bin/se...i?10093266.htm

    --
    Edison Ortiz
    Novell Product Support Forum SysOp
    (No Email Support, Thanks !)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •