I administer a small Netware 4.11+sp9 network, with three Windows XP
workstations and a Windows 2K workstation. I use IPX for my Netware needs,
exclusively. IP takes care of Windows and internet capabilities, over the
same Ethernet wiring, and in the same workstations.

Only one ("DAHLIA") of the XP workstations is problematical, and as it sits
some 40 miles across the Los Angeles metropolis from me, I cannot interact
with it during this posting. But I will nevertheless petition for advice.

All four workstations are running Client32 4.91+sp3. The same Novell
download for this client has been used for all four computers. It is a
single action to install this client; not a sequence.

Therefore I upgraded two essentially-identical Dell OptiPlex WinXP
workstations on April 22 ("DAHLIA" and "ORCHID"; these are older computers
dating to 2001). Since 2001, these two XP workstations had worked
flawlessly under Client32 v 4.82.

I serviced Dahlia before Orchid, given that it is the less valuable of the
two (lacks Microsoft Office software). I did NOT update Windows XP in
Dahlia before I installed Client32 4.91+sp3, which replaced Client 4.82. .
I DID update Windows in Orchid before I installed 4.91+sp3, because I was
suspicious of problems I noticed in Dahlia.

Orchid never exhibited any problems with Client32 4.91+sp3.

So what is wrong with Dahlia? I'll try to explain. Short answer? It has
no cognizance of "context," when I shell out to a cmd window. Within
Windows, context is no problem; I can use NWadmin32 and move around in the
NDS tree. But if I shell out to a cmd window, I get failures in my attempts
to capture LPT1 to a printing queue; and PCONSOLE and NETADMIN exhibit
conspicuous failures in ability to recognize context.

I still use DOS-like features, with shortcuts to DOS batch files, etc. So I
want my DOS context-recognition capability.

I worked on Dahlia for hours, to no avail, trying to resolve this problem.
I updated Windows XP in Dahlia. I uninstalled Client32 4.91+sp3,
re-installing Client32 v. 4.82. I mimicked Orchid, which works
successfully. I paid attention to the IP and IPX protocols, as viewed in
client properties, trying various approaches. In the end, I left Dahlia the
way I left Orchid, with "IPX only" as the client protocol, and installed
with Client32 4.91+sp3.

Any suggestions related to the recovery of context-recognition, under DOS,
would be greatly appreciated.


Sent via OE by John, from MERCURY