I am not sure if this is the right forum or not, if this is not, please
let me know.

I had this same issue a few months back:

I had this issue awhile ago and was able to get it resolved by
disableing the "UNC Filter" option but now I just got a new
workstation and I am having the same issue I disabled the UNC filter
but it is still going slow, This is the novell client version:

Thank you