Im trying to set up a two node cluster in our lab using old production
equipment (2 x compaq ml530, ra4100 shared storage, Compaq FibreChannel
HBA's). Everything runs smooth exept acessing the shared storage via the
Compaq HBA's.
This is the output from /var/log/messages after i load the kernel module
for the card:

cpqfc: unsupported module, tainting kernel.
cpqfcTS: New FC port 000001h WWN: 500508B100044B40 SCSI Chan/Trgt 0/0
------------[ cut here ]------------
kernel BUG at drivers/scsi/scsi_scan.c:1335!
invalid operand: 0000 [#1]
CPU: 1
EIP: 0060:[<e1494a00>] Tainted: PF U
EFLAGS: 00010213 (2.6.5-7.147-smp SLES9_SP1_BRANCH-200501270919290000)
EIP is at scsi_free_host_dev+0x50/0x60 [scsi_mod]
eax: ffffffff ebx: ccdc0000 ecx: cb98decc edx: dc990000
esi: d82ef200 edi: ccdc0000 ebp: dcf6ee00 esp: cd1b5c3c
ds: 007b es: 007b ss: 0068
Process cpqfcTS_wt_0 (pid: 6452, threadinfo=cd1b4000 task=cdbecd20)
Stack: 00000000 e20b9d9c dcf6ee00 cd1b5c78 cd1b5dfc ccdc0000 dcf6ee00
d42a0000 d41e0258 d41e0000 00000004 d42a0000 dc9901e0 00000001
0000023d dcbe843c 00000000 c015eeb8 dc990378 d8ede2e0 dcbe843c
Call Trace:
[<e20b9d9c>] cpqfcTS_WorkTask+0x65c/0x1430 [cpqfc]
[<c015eeb8>] handle_mm_fault+0x138/0xb60
[<c0128d50>] autoremove_wake_function+0x0/0x40
[<c0128d50>] autoremove_wake_function+0x0/0x40
[<e107fc38>] do_journal_end+0x208/0xcc0 [reiserfs]
[<c0120c67>] recalc_task_prio+0x1a7/0x3f0
[<c0121b8c>] activate_task+0x6c/0x80
[<c02c4590>] alloc_skb+0x40/0xf0
[<c0121eff>] move_tasks+0x30f/0x490
[<c0119fca>] smp_send_reschedule+0x1a/0x20
[<c0120807>] __wake_up_locked+0x17/0x20
[<e20bacf3>] cpqfcTSWorkerThread+0x183/0x1f2 [cpqfc]
[<c0109126>] ret_from_fork+0x6/0x20
[<e20bab70>] cpqfcTSWorkerThread+0x0/0x1f2 [cpqfc]
[<c0107005>] kernel_thread_helper+0x5/0x10

Code: 0f 0b 37 05 37 b2 49 e1 eb b6 8d b6 00 00 00 00 55 89 c5 57
<6>scsi0 : Compaq FibreChannel HBA Tachyon TS HPFC-5166A/1.2: WWN
on PCI bus 0 device 0xa0fc irq 17 IObaseL 0x1400, MEMBASE 0xf6040000
PCI bus width 64 bits, bus speed 66 MHz
FCP-SCSI Driver v2.5.4
GBIC detected: Short-wave. LPSM 0h Monitor
@Linux _abort Scsi_Cmnd cb919c80 in BoardLockCmnd Q
scsi: Device offlined - not ready after error recovery: host 0 channel 0
id 0 lun 0

The cards have a really weak naming, they are called "Compaq Fibre
Channel 64-bit/66Mhz HBA" and are 1GBit/s cards. They used to work fine
with Red Hat Linux 8 (2.4 kernel).

Any help welcome! :)

Marcus Nilsson
University of Vxj, It-department
Phone:+46 (0)470 - 708087
Cell:+46 (0)708 - 901073