I've got an OES-NW cluster where I've been swapping Apache between nodes for
some time now. I upgraded Apache to 2.0.58, first on a non-cluster machine,
then on the cluster. On the non-cluster machine, there was no problem, I
extracted the download, removed the default conf and copied it over the
existing directory. All worked well. On the first cluster node, same result.
On the second cluster node, Apache will not load when migrating the apache
service. The log says, "(OS 10049)Can't assign requested address: make_sock:
could not bind to address secondaryIP:443" where secondaryIP is the IP of
the apache cluster object. It then reports no listening sockets and aborts.
When I look at Apache Manager on the cluster node (before attempting
migration) where the cluster node is not loaded, it reports "Current Server
Status: UP." Before, it would correctly report that the apache server was
down. I cannot stop it - the manager reports that the action fails, after
all, apache is not really loaded. Doing "m apache2" reports that apache2.nlm
is loaded for address space ADMSRV only. Why does the server think that the
apache server is up? TCPCON shows that the secondaryIP is added. The apache
storage pool is active and the volume is mounted. What else?

Erick Larson
Perkins Library
Duke University