I had a problem getting OES Linux Cluster to work on VMware ESX server.
I have searched the forums and Google, and there were other people with the
same issue.
The issue was that when clustering was started on the node it would
completely reboot the server (no kernel panic, just a cold reboot).
We have found the solution to the issue, so I want to share it for other
people with the same issue.

VMware has a problem with time synchronization on the guests (many hits on
The suggested solution is to put an option to the /boot/grub/menu.lst file
This indeed solves the timesync problem, but it also the cause of the problem.
The solution is to change pit to pmtmr, this solves both problems.