Hi,

I've got a 2 node Novell Cluster with Novell OES SP2 (cluster service
1.8.2) running OES/Linux (SLES 9 SP3)..

I configured a samba resource with EVMS volume..but when I tried to bring
it online, the resource is going into the COMATOSE state...I am failing to
understand why and even the cluster logs are not much helpful..I also
looked at the system logs (/var/log/messages/samba/*.log) on both the
nodes, but not much help....

Will appreciate if anyone can just provide any hints or tips to debug it..

Here are my samba-resource load/unload scripts :
++++++++++++++++++++++++++++++++++++++++++++++++++ +++++++++++++++++
#!/bin/bash
.. /opt/novell/ncs/lib/ncsfuncs

SAMBA_ROOT=/mnt/samba/vol1
# define the IP address
RESOURCE_IP=a.b.c.d
# define the file system type
MOUNT_FS=ext3
# define the device
MOUNT_DEV=/dev/evms/lvm/system/samba_1
# define the mount point
MOUNT_POINT=/mnt/samba/vol1

# define the name of the samba config file
CONFIG_FILE=cl_vol1_smb.conf

# mount the file system
exit_on_error mount -t $MOUNT_FS $MOUNT_DEV $MOUNT_POINT

# add the IP address
exit_on_error add_secondary_ipaddress $RESOURCE_IP

# start Samba
exit_on_error /usr/sbin/nmbd --log-basename=$MOUNT_POINT/log
--configfile=$MOUNT_POINT/etc/samba/$CONFIG_FILE
exit_on_error /usr/sbin/smbd --log-basename=$MOUNT_POINT/log
--configfile=$MOUNT_POINT/etc/samba/$CONFIG_FILE

# return status
exit 0

++++++++++++++++++++++++++++++++++++++++++++++++++ +++++++++++++++++

The UNLOAD script is as follows:
--------------------------------------------------------------------
#!/bin/bash
.. /opt/novell/ncs/lib/ncsfuncs

SAMBA_ROOT=/mnt/samba/vol1
# define the IP address
RESOURCE_IP=a.b.c.d
# define the mount point
MOUNT_POINT=/mnt/samba/vol1

# define the name of the samba config file
CONFIG_FILE=cl_vol1_smb.conf

# request Samba stop
ignore_error killproc -p /var/run/samba/nmbd-$CONFIG_FILE.pid /usr/sbin/nmbd
ignore_error killproc -p /var/run/samba/smbd-$CONFIG_FILE.pid /usr/sbin/smbd

# stop Samba otherwise
sleep 8
ignore_error fuser -k $MOUNT_POINT

# del the IP address
ignore_error del_secondary_ipaddress $RESOURCE_IP

# umount the file system
exit_on_error umount $MOUNT_POINT

# return status
exit 0
--------------------------------------------------------------------

I also copied the "smb.conf" file from /etc/samba/ to my
$MOUNT_POINT/etc/samba/cl_vol1_smb.conf and have used EVMS to crate the
volume to be shared via SAMBA. But something is preventing samba to work
correctly...


Here is my samba config file for cluster (cl_vol1_smb.conf)
################################################## ###########
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-12-01
[global]
workgroup = workgroup
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
bind interfaces only = yes
interfaces = IP_ADDR_OF_INTERFACE
pid directory = $SAMBA_ROOT/share/locks


# BEGIN - Entries made by OES install
#netbios name = %h-W
netbios name = SAMBACLUSTER
passdb backend = NDS_ldapsam:ldaps://LDAP_SERVER_IP:636 smbpasswd
ldap admin dn = cn=admin,o=example
ldap suffix = o=example
ldap idmap suffix = o=no
ldap machine suffix = o=example
ldap passwd sync = on
security = user
encrypt passwords = yes

# NOTE: use sendfile is set to no to support nss filesystem shares.
# To improve performance for other filesystems that support
# sendfile remove this line from the global section and add only
# to share definitions on nss filesystems.
use sendfile = no

# NOTE: The following settings are needed when acting as the PDC.
# domain logons = Yes
# os level = 65
# preferred master = Yes
# domain master = Yes
# passwd program = /opt/IDEALX/sbin/smbldap-passwd "%u"
# add user script = /opt/IDEALX/sbin/smbldap-useradd "%u"
# delete user script = /opt/IDEALX/sbin/smbldap-userdel "%u"
# add machine script = /opt/IDEALX/sbin/smbldap-useradd -w "%u"
# add group script = /opt/IDEALX/sbin/smbldap-groupadd -p "%g"
# delete group script = /opt/IDEALX/sbin/smbldap-groupdel "%g"
# add user to group script = /opt/IDEALX/sbin/smbldap-groupmod -m
"%u" "%g"
# delete user from group script = /opt/IDEALX/sbin/smbldap-groupmod
-x "%u" "%g"
# set primary group script = /opt/IDEALX/sbin/smbldap-usermod -g "%g"
"%u"# add share command = /opt/IDEALX/novell/addSambaShare

# END - Entries made by OES install

[homes]
comment = Home Directories
valid users = %S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
[myshare]
comment = shared directory -- This is shared via Novell Cluster
path = /mnt/samba/vol1/my_shared_dir
read only = No
################################################## ###########

Any help will greatly be appreciated.

Thanks,
Dharmesh.