You're encountering the NAT loopback problem. Most NAT vendors
(including
Novell) run into this. Basically, private resources cannot access
other
private resources via a public NAT address.

The "solution" is dual resolution. Enter a DNS name in the iFolder
field
as you've done. Make sure internal users/workstations resolve this
address to the private address. Public users need to resolve to the public/NAT address.

> Hi, my setup is:
> iFolder 2.0 running on Redhat Linux 7.2, Edir 8.7.
> I have iFolder running on a server with an internal IP address

connected
to
> a Router using NAT with the appropriate ports being forwarded to the


server.
> If I login to the management console and go to Global settings and

enter
the
> DNS address of the server for the Public location, users on the

inside
can
> no longer access iFolder - they get the error "Check user error:

-35".
If I
> change the public DNS entry to the internal IP address of the server

then
> things work fine internally but of course, it doesn't work

externally.
>
> I have put an entry in the Hosts file so that the dns entry resolves

to
the
> internal IP address for internal users but it still doesn't work.

If I
ping
> the dns entry, it resolves internally so I know that's working.

Does
anyone
> have any clues as to what might be wrong?
>
> thanks
> Arend
>
>