Have you tired to get an updated Java for the WS? I have 1.4.1 from
Sun.