Home

Results 1 to 6 of 6

Thread: unable to login to management console

  1. #1
    dan@nomail.com NNTP User

    unable to login to management console

    I am running iFolder 2.0 on a NW6 sp2 server. After I install iFolder,
    I
    can not login to the management console. During the install I
    designated
    the only user as Admin. Is this the same "admin" username that resides
    in
    my tree or is this a seperate account. When i designate the username (during installation) do I have specify the context the user resides
    in. I
    am at a loss. Any help would be appreciated.




  2. #2
    AndersG NNTP User

    Re: unable to login to management console

    ,
    > Is this the same "admin" username that resides in
    > my tree or is this a seperate account. When i designate the username


    > (during installation) do I have specify the context the user resides

    in. I
    > am at a loss. Any help would be appreciated.
    >

    Yes, but it is case sensitive and the context matters.

    - Anders Gustafsson, Engineer, CNE5, ASE
    NSC Volunteer Sysop (http://support-forums.novell.com)
    Pedago, The Aaland Islands (N60 E20)
    Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195





  3. #3
    dan@nomail.com NNTP User

    Re: unable to login to management console

    > ,
    > > Is this the same "admin" username that resides in
    > > my tree or is this a seperate account. When i designate the

    username
    > > (during installation) do I have specify the context the user

    resides
    in. I
    > > am at a loss. Any help would be appreciated.
    > >

    > Yes, but it is case sensitive and the context matters.
    >
    > - Anders Gustafsson, Engineer, CNE5, ASE
    > NSC Volunteer Sysop (http://support-forums.novell.com)
    > Pedago, The Aaland Islands (N60 E20)
    > Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195


    OK, so what do I have wrong. I can't figure it out. Here is the
    http_additions_nw.conf.
    #
    # iFolder Server LoadModule
    #
    LoadModule ifolderserver_module "iFolder/Server/iFolder.nlm"

    #
    # iFolder User LoadModule
    #
    LoadModule ifolderuser_module "iFolder/Server/iFolderu.nlm"

    #
    # Edit the xxx.xxx.xxx.xxx to your IP address
    # =================================
    <VirtualHost 192.168.1.2:50080>

    ServerName 192.168.1.2

    DocumentRoot "SYS:\apache\iFolder\DocumentRoot"
    iFolderApplicationRoot "SYS:\apache\iFolder\Server"

    <Directory "SYS:\apache\iFolder\DocumentRoot">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    <location /iFolderServer>
    SetHandler ifolderserver-form-handler
    </location>

    <location /iFolder>
    SetHandler ifolderuser-form-handler
    </location>



    #
    # iFolder Server LDAP Settings
    #
    # Edit the LdapHost
    # if the SSL LDAP port of 636 is used, you must
    # enter the path to the LdapRootCert.
    # ==============================================
    LdapHost 192.168.1.2
    LdapPort 389
    LdapLoginDnContext "ou=personal.o=home"
    # -or -
    # LdapLoginDnContext ",ou=xxxx,o=xxxx"
    # LdapRootCert "%LdapRootCert%"

    #
    # iFolder Volume \ directory for user files
    #
    # Edit the iFolderServerRoot
    # Edit the iFolderUserRoot (same as iFolderServerRoot, used by
    iFolderUser module)
    # =================================
    iFolderServerRoot SYS:\iFolder
    iFolderUserRoot SYS:\iFolder

    #
    # iFolder Volume \ directory for application files
    #
    # Edit the iFolderApplicationRoot
    # =================================
    ## iFolderApplicationRoot I:\Apache\iFolder\Server

    #
    # iFolder Admin Settings for Server Management Console
    #
    # Edit the iFolderAdminName
    # ==================================
    iFolderAdminName admin

    #
    # iFolder Server Secure Port
    #
    # Edit the ServerSecurePort
    # ==================================
    ServerSecurePort 50443
    iFolderUserServerSecurePort 50443
    #
    # iFolder Server Non-Secure Port
    #
    # Edit the ServerNonSecurePort
    # ==================================
    ServerNonSecurePort 50080
    iFolderUserServerSecurePort 50443

    #
    # iFolder Server DNS or IP
    #
    # Edit the iFolderServerDNSorIP
    # ==================================
    iFolderServerDNSorIP 192.168.1.2
    iFolderUserServerDNSorIP 192.168.1.2

    </VirtualHost>

    # Virtual Host for SSL Port 50443

    #
    # Edit the xxx.xxx.xxx.xxx to your IP address
    # =================================
    <VirtualHost 192.168.1.2:50443>

    BrowserMatch "MSIE" nokeepalive downgrade-1.0 force-response-1.0

    ServerName 192.168.1.2

    DocumentRoot "SYS:\apache\iFolder\DocumentRoot"
    iFolderApplicationRoot "SYS:\apache\iFolder\Server"

    <Directory "SYS:\apache\iFolder\DocumentRoot">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    <location /iFolderServer>
    SetHandler ifolderserver-form-handler
    </location>

    <location /iFolder>
    SetHandler ifolderuser-form-handler
    </location>


    #
    # iFolder Server LDAP Settings
    #
    # Edit the LdapHost
    # if the SSL LDAP port of 636 is used, you must
    # enter the path to the LdapRootCert.
    # ==============================================
    LdapHost 192.168.1.2
    LdapPort 389
    LdapLoginDnContext "ou=personal.o=home"
    # -or -
    # LdapLoginDnContext ",ou=xxxx,o=xxxx"
    # LdapRootCert "%LdapRootCert%"

    #
    # iFolder Volume \ directory for user files
    #
    # Edit the iFolderServerRoot, iFolderUserRoot
    # =================================
    iFolderServerRoot SYS:\iFolder
    iFolderUserRoot SYS:\iFolder

    #
    # iFolder Volume \ directory for application files
    #
    # Edit the iFolderApplicationRoot
    # =================================
    ## iFolderApplicationRoot I:\Apache\iFolder\Server

    #
    # iFolder Admin Settings for Server Management Console
    #
    # Edit the iFolderAdmin lines
    # ==================================
    iFolderAdminName admin

    #
    # iFolder Server Secure Port
    #
    # Edit the ServerSecurePort
    # ==================================
    ServerSecurePort 50443
    iFolderUserServerSecurePort 50443

    #
    # iFolder Server Non-Secure Port
    #
    # Edit the ServerNonSecurePort
    # ==================================
    ServerNonSecurePort 50080
    iFolderUserServerNonSecurePort 50080

    #
    # iFolder Server DNS or IP
    #
    # Edit the iFolderServerDNSorIP
    # ==================================
    iFolderServerDNSorIP 192.168.1.2
    iFolderUserServerDNSorIP 192.168.1.2

    </VirtualHost>

    >






  4. #4
    AndersG NNTP User

    Re: unable to login to management console

    ,
    > "ou=personal.o=home"
    >

    And the full dn for admin is cn=admin.ou=personal.o=home?

    - Anders Gustafsson, Engineer, CNE5, ASE
    NSC Volunteer Sysop (http://support-forums.novell.com)
    Pedago, The Aaland Islands (N60 E20)
    Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195





  5. #5
    dan@nomail.com NNTP User

    Re: unable to login to management console

    Yes, the full dn for admin is cn=admin.ou=personal.o=home. Also the
    LDAP
    objects reside at this context. Do I have something configured wrong?
    I
    installed 1.01 last night and I could login fine, when I upgraded to
    2.0
    again, I ran into the same problem.
    Thanks for the help, I really appreciate it.


    > ,
    > > "ou=personal.o=home"
    > >

    > And the full dn for admin is cn=admin.ou=personal.o=home?
    >
    > - Anders Gustafsson, Engineer, CNE5, ASE
    > NSC Volunteer Sysop (http://support-forums.novell.com)
    > Pedago, The Aaland Islands (N60 E20)
    > Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195
    >






  6. #6
    AndersG NNTP User

    Re: unable to login to management console

    ,
    > Do I have something configured wrong? I
    > installed 1.01 last night and I could login fine, when I upgraded to

    2.0
    > again, I ran into the same problem.
    >

    Ah... I remember seeing some issues with upgrades, but here are a few

    things to try:

    IFolder simple troubleshooting steps:
    1. iFolder 2.x needs eDirectory 8.6.2 or better for LDAP. It will not
    work
    with NW 5.1 DS 8.82 for example.
    2. Check that the admin name in the iFolder server config file is
    correct
    3. Use the clear-text LDAP port for troubleshooting
    4. Turn on LDAP tracing on the LDAP Server/Group Object
    5. LOAD DSTRACE. Turn off everything and turn on LDAP, then try to log
    in.

    - Anders Gustafsson, Engineer, CNE5, ASE
    NSC Volunteer Sysop (http://support-forums.novell.com)
    Pedago, The Aaland Islands (N60 E20)
    Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195





Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •