If I upgrade iFolder serverfiles from 2.0 to 2.1 do I need to update
the clients
also? So does 2.1 server-side work with 2.0 clients?

I have a lot of users who are have a very little knowledge about
computers so if the upgrade would be completely invisible to them I
could do it.

I have no real reason to upgrade from 2.0 to 2.1 at the moment. We
have no performance issues with the server and the changes between the

versions deal with those issues mostly to my knowledge.

But if the upgrade would be made only to server-side then I could do
it now for the future in mind when we will implement iFolder maybe
corporate wide.

Best Regards and thank you for your replys in advance
Antti Mattila