I am running iFolder 2.1.2 on NW Server 6.5 sp1 in single tree. LDAP and
iFolder Servers are all on this box, which contains a R/W replica. This
is the only 6.5 server in tree, DSREPAIR returns no errors. Tree
contains 4.11/5.0/5.11 and NWDEPLOY was ran prior to introducing 6.5 to
tree. No errors during install and all other products, such as Virtual
Office, perform as expected.

ifoldr worked for short period when I tested for one user, but after
moving data storage from SYS to a DATA volume additional user creations
fail when the user tries to initialize the account. Intially I would see
subfolders below \ifolder of \9C and \ACCOUNTS, but since problems occur
only logs are seen in ifolder directory with no subfolders.

Process is I enable user through iFolder administator, user tries to
login, if they try to encrypt files message "Authentication failed (-25)
is reported back--if they login with no encryption they can successfully
login but "Server sync failed" is reported on any actions.

I tried re-install by deleting iFolder_Settings, iFolder_ldap01, and
iFolder_server01 objects from eDirectory (did not delete
iFolder_ServerAgent). Also deleted all ifolder related file structure
directories, then re-installed.

Below is error log when users try to initialize. (The reference to
DIRCON.DAT being corrupt or missing is due to this is the one account
that worked initially, but the file is no longer there after disabling
and re-enabling the user). Other users are newly created and have never
worked.

PARTAIL ERROR LOG:
06/25/04 08:02:41 Checking user accounts...
06/25/04 08:02:41 Total user@folder files = 0
06/25/04 08:02:41 Total number of accounts = 0
06/25/04 08:02:41 User account check complete
06/25/04 08:10:35 iFolderService key pair generated
06/25/04 08:10:35 NIF CertHandler: Root certificate file for master ldap
not found, requesting a new one from server.
06/25/04 08:10:35 NIF CertHandler: # Root Certs=1.
06/25/04 08:10:35 NIF CertHandler: Retrieved certificate of size=1279.
06/25/04 08:51:24 LOCATE_SERVER jott unprovisioned user
06/25/04 08:51:33 LOCATE_SERVER jott unprovisioned user
06/25/04 11:00:51 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:11:32 LOCATE_SERVER mbuchana.scnr.bms authentication failure
06/25/04 11:11:40 LOCATE_SERVER mbuchana.scnr.bms authentication failure
06/25/04 11:17:48 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:17:59 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:18:13 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:18:26 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:18:39 mbuchana/home: machId:? - LOGIN encryption mismatch
06/25/04 11:25:18 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:25:18 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:25:45 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:25:45 admin/home - check user begin
06/25/04 11:25:45 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:25:45 admin/home - dircon.dat missing
06/25/04 11:25:45 admin/home - new databaseId: 40dc5209
06/25/04 11:25:45 admin/home - check user complete
06/25/04 11:26:00 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:00 admin/home - check user begin
06/25/04 11:26:00 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:00 admin/home - dircon.dat missing
06/25/04 11:26:00 admin/home - new databaseId: 40dc5218
06/25/04 11:26:00 admin/home - check user complete
06/25/04 11:26:06 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:06 admin/home - check user begin
06/25/04 11:26:06 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:06 admin/home - dircon.dat missing
06/25/04 11:26:06 admin/home - new databaseId: 40dc521e
06/25/04 11:26:06 admin/home - check user complete
06/25/04 11:26:27 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:27 admin/home - check user begin
06/25/04 11:26:27 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:27 admin/home - dircon.dat missing
06/25/04 11:26:27 admin/home - new databaseId: 40dc5233
06/25/04 11:26:27 admin/home - check user complete
06/25/04 11:26:49 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:49 admin/home - check user begin
06/25/04 11:26:49 admin/home - unable to open DIRCON.DAT corrupted
06/25/04 11:26:49 admin/home - dircon.dat missing
06/25/04 11:26:49 admin/home - new databaseId: 40dc5249
06/25/04 11:26:49 admin/home - check user complete
06/25/04 11:48:04 jkeys/home: machId:? - LOGIN encryption mismatch
06/25/04 14:13:22 jkeys/home: machId:? - LOGIN encryption mismatch
06/25/04 14:13:51 jkeys/home: machId:? - LOGIN encryption mismatch
06/25/04 14:14:08 jkeys/home: machId:? - LOGIN encryption mismatch

Sorry for length, but trying to supply ifo I think you might need. Also
I installed iFolder and 6.5 (non sp1) several times on lab server with no
issues.

Any help is greatly appreciated.

Mick Buchanan