I was having issues getting the client installed on 9.3, but after
installing the pre-request from Mono it went smoothly.

add red carpet service http://go-mono.com/download and install the latest
required packages from the mono 1.1x channel: mono-core, mono-data,
mono-web, libgdiplus, xsp, and the gtk-sharp from the Gtk# 1.0x channel.