Hello,

I'm not having any luck getting iFolder to work properly on one of the Macs
I have.
Basically, when I enter my account information in the iFolder client, and
click "Log In", a message pops up saying "An error was encountered while
connecting to the iFolder server".

I'm running a new Intel iMac (Tiger), and I'm wondering if that has
something to do with it. I've tried Mono 1.1.15 (the new x86 build for OS
X) and several other different versions. I've also tried many different
builds of iFolder, and they all have the same behaviour.

When I run iFolder from the terminal, here's the output:

2006-06-23 10:52:34.673 iFolder 3[5549] Starting Simias Process
2006-06-23 10:52:34.674 iFolder 3[5549] Enabling multithreaded processing
Cannot open directory /etc/simias: No such file or directory
Cannot file default mapping file /etc/simias/SimiasDirectoryMapping: No
such file or directory
2006-06-23 10:52:34.819 iFolder 3[5549] Loading application defaults
2006-06-23 10:52:34.830 iFolder 3[5549] Showing iFolder Window
2006-06-23 10:52:35.043 iFolder 3[5549] Initialized iFolderService on URL:
/iFolder.asmx
2006-06-23 10:52:35.045 iFolder 3[5549] Initialized SimiasService on URL:
/Simias.asmx
Ping exception: Error: ConnectFailure
Simias
Adding applications '/simias10:web'...
Registering application:
Host: any
Port: any
Virtual path: /simias10/
Physical path: /opt/novell/ifolder3/web
Listening on port: 60247
Listening on address: 0.0.0.0
Root directory: /opt/novell/ifolder3
2006-06-23 10:52:35.721 iFolder 3[5549] Setup to monitor proxy changes
Simias Application Path: /opt/novell/ifolder3
Simias Data Path: /Users/asantoni/.local/share/simias
Run in client configuration
Local service port = 60247
Simias Process Starting
Simias Process Running
2006-06-23 10:52:37.259 iFolder 3[5549] Simias Process Running
2006-06-23 10:52:37.260 iFolder 3[5549] reading Simias credentials
2006-06-23 10:52:37.261 iFolder 3[5549] Initialized SimiasService on URL:
http://127.0.0.1:60247/simias10/Simias.asmx
2006-06-23 10:52:37.262 iFolder 3[5549] Initialized iFolderService on URL:
http://127.0.0.1:60247/simias10/iFolder.asmx
2006-06-23 10:52:37.262 iFolder 3[5549] initializing Simias Events
2006-06-23 10:52:37.274 iFolder 3[5549] Creating and loading iFolderData
2006-06-23 10:52:37.275 iFolder 3[5549] Refreshing iFolderData
2006-06-23 10:52:37.277 iFolder 3[5549] Event client connected
2006-06-23 10:52:37.311 iFolder 3[5549] Exception refreshing iFolderData
2006-06-23 10:52:37.312 iFolder 3[5549] Exception in iFolderData:refres:
SOAP Error 29 SOAP error in SimiasService.GetDomains
2006-06-23 10:52:37.312 iFolder 3[5549] Done Refreshing iFolderData
2006-06-23 10:52:48.796 iFolder 3[5549] Initialized SimiasService on URL:
http://127.0.0.1:60247/simias10/Simias.asmx
2006-06-23 10:52:48.797 iFolder 3[5549] Initialized iFolderService on URL:
http://127.0.0.1:60247/simias10/iFolder.asmx
2006-06-23 10:52:48.803 iFolder 3[5549] Exception in
Accounts:awakefromNib:GetDomains: SOAP Error 29 SOAP error in
SimiasService.GetDomains
2006-06-23 10:52:48.849 iFolder 3[5549] Initialized iFolderService on URL:
http://127.0.0.1:60247/simias10/iFolder.asmx

****** Now, if I set up a new account and click "Log In", this happens:

2006-06-23 10:54:01.425 iFolder 3[5549] iFolder encountered an exception
while clearing the proxy
2006-06-23 10:54:01.426 iFolder 3[5549] Exception in setupSmiasProxies:
SOAP Error 29 SOAP error in SimiasService.SetProxyAddress
2006-06-23 10:54:01.433 iFolder 3[5549] iFolder encountered an exception
while clearing the proxy
2006-06-23 10:54:01.433 iFolder 3[5549] Exception in setupSmiasProxies:
SOAP Error 29 SOAP error in SimiasService.SetProxyAddress
2006-06-23 10:54:01.441 iFolder 3[5549] Exception in ConnectToDomain: SOAP
Error 29 SOAP error in SimiasService.ConnectToDomain


If anyone could provide me with any hints or suggestions, it would be
greatly appreciated.

Thanks!

P.S. I have iFolder working fine on an OS X Tiger PPC laptop... just not
this Intel iMac...